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Adobe InDesign CS1 Export Adobe PDF (Windows)

Preliminary configuration:

& Adobe InDesign C5 3.0.1

File | Edit Layout Type Obiect Table View ‘window Help Conﬁgure InDesign CS Color Settings:
F Undo Define Presets Ctil+Z
Bl * Select Edit > Color Settings
i (5ot [Birl e
B o ® Activate the checkbox for Enable Color Management
| & | Bhstir Aleazali
'T} E‘asle fri e A\t+:hlltl:l2trl+\/ ® Select the Load button
7 . - . .
@, oon AR ® Navigate to the folder containing the Sheridan Color Settings file*
M
At s ® Choose the Sheridan.csf file and select the Open button
- Elifm St Editan Eife . . . .
— [ *Alternatively, prior to loading, the Sheridan.csf file may be located to:
F S E e e 2 ifla =
Firel ez lerrile s . . .
Tﬁ? Chezk Sprling.. Bt C:\Program Files\Common Files\Adobe\Color\Settings
4 Dictionary
Transparency Blend Space 3
I Transparency Flattener Presets... Color Settings

%M ¥ Enable Colar Managernent
== Eanverte Biole
’E Keyboard Shortcuts. Settings: |Cn|nr Management Off j
= Freene= ! I Advanced Mode Load Color Settings JE E3
— Working Spaces
: RGB: [Moritor RGE - sRGE IECA1966-2,1 =l Look i [ 3 Cola E[RGER S
YK U5, web Coated (SWOP) w2 =l g 2
— Color Management Policies
RGE: [Off =l
cwavk: [off =l

Profie Mismatches: v Ask When Opening
I e BAs G,

Missing Profiles: [ 2st Vihen Opering

Description:

Position the pointer over  heading to view a description.

File name: IShendan j Open

AN

Files of type: [ Color Settings Fies =l

B

Color Settings

® Select OK from the Color Settings dialog window

¥ Enable Color Management

Settings: |Sher|dan =l
¥ Advanced Made Load...
— Wiorking Spaces . |
RGB! [Adabs RGB (1598) =]
CMVK: [U.5. Web Coated [SWOR) v2 =l

— Color Management Policies

RGE: |Preserve Embedded Profiles
MK [off

Profile Mismatches: M Ask When Opening
¥ 2sk When Pasting

Missing Profies: [ Ask When Opening

-~ Conversion Options
Engine: |Adobe (ACEY

Intent: |Re\ative Colorimetric

[ (N

¥ Use Black Paint Compensation

Diescription:
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& Adobe InDesign CS 3.0.1

RFae il L e RDect T Yo i o Confirm InDesign CS General Preferences for Print Options:

J§z Unda Clear CirkZ r (Bl E
| BE  Redo =i e
r - 0
— o = 2= ® Select Edit > Preferences > General
@ 104%

< Eopy [Brl 5 o 0 3 % X .

= . e, :-k Ak ® Activate the checkbox for Overprint [Black] Swatch at 100%
| FasteimElaee S (St s

Q‘ E=xig Backspane ° Se|eCt OK

f‘ inliEate Al

=, Sleae) el iz S Rl . ..
M— o Note: The checkbox for Overprint is invoked by default

eselectall = Bl 3

2 e il

2 e Ok

S Find st At Chf

“ Check Speling Cul+l N - | General

0 oietonay. . p—

E Tiameearay Bl e s e View: [Section Humbering = ‘

- Transparency Flattener Presets.. Grids
Guides & Pasteboard

General Options

Color Settings.. Dictionary
Agsign Profiles. Spelling
Convert ta Profile... Story Editor Display

Toal Tips: |Mormal >
Finating Tools Palette; [Double Column ~
Display Performance
File Handing

Updates Print Cptions
RN L —— |

Keyboard Shertouts

Tet..
Farit Downloading and Embedding
lvays subset fonts with glyph counts greater than: [2000

Composition
Cipboard

Uniits & Increments. .
Grids.

™ Prefer FDF hen Pasting [¥ Copy POF ta Ciphoard
I~ Preserve Text Attributes When Pasting

Guides & Pasteboard..
Dictionary.

b, seusgeoa ]|

Speling...

Story Editor Display.
Display Performance:
File Handling.. =
Updates.

Reset All Warning Didlogs

Cancel

& ydeabeeq

Configure InDesign CS Transparency Blend Space*:

_File | Edit Lapout Type Obect Table View ‘Window Help

THE SHERIDAN PRESS

ency Flattener

Colar Setlings...
Assign Profiles
oy b Pl

Keyboard Shartcuts..
Preferences 4

Canwert All Strokes to Gutlines: OF
Clip Compler Regions: Mf&

Urdn Define Presets— CikZ e r El_
e ShifCiiZ .
= e * ¢ Select Edit > Transparency Blend Space > Document CMYK
Tt it
Copy Tt
Faste ity
Raste I Al
[ A Configure InDesign CS Transparency Flattener Presets:
pace
[nlicats: e e Egki ) o .
g o Select Edit > Transparency Presets...
CHERE i . .
°
D Desdectil ift-Crlets Select [High Resolution]
52 £t Sty Eeltar il
— °
A F CHF Select OK
il Rtz At Sh{
v gwet:k Eoelg i TS oEE
ictionan
— * F\Ie Edit Lapout Tppe Object Table “iew ‘Window Help
Document RGE
Undo Define Presets ChrleZ E @
Tranzparency Flattener Fresels J §§ Feda itz A Eﬁ ’7 E_
|3 Color Setiings — e
’i[ ki) Feifil < Copy CHIAE
E ConvetinPofie | =
’E Keyboard Shortcuts. ’T aste it ke Transparency Flattener Presets
Prefersnces 3 S| PesleinPlece Al
| :3‘ [E[EEr; EEclsyace Prasats:
[ ®‘ Wiplicate e il e [Lowe Resolution] -
= S i Medium Resolufion
. = el Eat Fifhesy ey,
*Note: Transparency Blend Space determines e ShitaCklH =
[ . JE-
the output color space subsequent to = EdndloyEe  Dikh -
fl ing for d .. P Gl e
attening tor documents containing W FindMest i Preset Settings:
H S EheckSpeling.. | astariector Balancs: = Load...
tl"ansparent Ob]eCtS. {ﬂ) Dictionary. Ene‘An an:l T:n Resul:tow?n: 1200 ppi B
— Gradient and Mesh Resolution: 200 ppi Save...
L_[ Transparency Blend Space N Conwert All Text ta Outinest OF
F
i
(=]
q
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[File Edit Laout Type Objest Tabls View ‘Window Help Conﬁgur‘e InDesign CS Document Presets:

et ¢ . [EE JE [ i
e e e L) = ® Select File > Document Presets > Define
e Culew el R
Save s (S ® Select New*
Save As Shift+Clrl+5 T T T
prvestomn ALOES — ® Assign a Document Preset name
EVET
e CHleD ® Configure fields for Page Size, Columns, and Margins relative to
PDF E it Procel ' the specifications for the particular publication
Export... Chl+E

® Select the Facing Pages checkbox

Egl [ ]

Document Setup... Al+Chl+P
D nent Pr

File Infa... [Defaul]...

Set Bleed and Slug to 0 for all page sides

Praflight. Alt+Shift+ Chil+F
Package...  Al+Shift+Cil+P
Package far Golive.

Frint Presets >
Prirt... Chil+P

® Select OK

New Document Preset
Document Preset: |EL375 ¥ 10.875 ‘ Ok '
Mumber of Pages: |5 ¥ Facing Pages g_—]
i Bt Frame
Fewet Options
— Page Size: |Custom vl _—

width: EB.S?S in Crientation: @ =
Height: EIU.EPS in

Document Presets

Exit Chl+

Presets:

[DEIEHE
ﬁ! Load...

Preset Settings:

Preset: [Defaul] T -
Page information
Murnber of Pages: 1 Save.., MUmbet: 1 Gutter: 0.1667 in
Facing Pages Tes E E
Master Text Frame: Mo
Page Width: 3.5 in
Page Height: 11in =l -~ Margins

Top: EU.ES in ‘ﬂ'
Bottorm: EU.ES in -

— Bleed and Slug

Inside: EUZS in
Outside: EUZS in

*Note: Repeat to add Document Presets

for varying publication specifications

Top Bottom Inside Outside
Bleed: |U in |U in |U in |U in &*
Slug: |U in |U in |U in |U in &*

& Adobe InDesign C5 3.0.1

File Edit Lapout Type Object Table View ‘Window Help

I BETINCEI
Open... Chrl+0 Book.

Open Recent ¥ Libray.

Use Document Presets when creating a new InDesign CS document:

® Select File > New > Document

Close Crksd

® Select the pre-configured Document Preset from the drop-down

Save Chl+G P N N Ll
Saeds.  ShiliCuk list appropriate for the particular publication
Save aCopy.. Al+Chil+5
Revert
® Select OK
Flace.. Chl+Dr
Import oML | E—
Expart... Chl+E
Document Preset: | [Default] j [ (s[4 | Document Preset:
Document Setup.. Al+Cil+P TCustom] k
Document Presets L3 MNumber of Pages: Cancel Mumber of Pages: IE ¥ Facing Pages ames
File Info [Default] ¥ Master Text Frame
2.5 x 11 DocMstr Save Preset... Save Preset...
Preflight.. AlShift+ ClileF — Page Size: |Letter |y g e — Page Size: ICustDm -
Package...  Al+Shift+Cil+P o Fewer Options Fewer Options
Package for Fialive width: [£]8.5in width: £]8.375 in Orientation; @ 2
Print Presets & Height: En in Height: Em.s?s in
Frint Chil+P
Exit Ctrl+0) — Coluring — Colurmns
Nurnber: El Gutter: EU‘IE;G? in Murmber: El Sutter: Eulﬁﬁ? in
— Margins — Margins

Top: ED.S in 2
Bottom: EU.S in :

Inside: ED‘S in

Top: ED.ZS in \a
Quitside: EU‘S in

Battem: [50.25 n .

Inside: EDQS in
Cutside: EDQS in

— Bleed and Slug

— Bleed and Slug

Top Eottom Inside Outside Top Bottom Inside Outside
Eleed: |D in |D in |D in E Eleed: |El in |El in |El in |El in 3
Slug: |D in |D in |D in E Slug: |D in |D in |D in |D in 3
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File Edt Layoul Type DObject Table Wiew Window Help Conﬁgure InDesign CS PDF EXPOI’t Presets:
i ' E]= I [ =
oS = e L= * Select File > PDF Export Presets > Define
[Else (SR
G Gl ® Select Load
GavELE iR kes)
iBop.  HsAA ® Navigate to the folder containing the Sheridan PDF Export Preset
EYEN
m-:c;mm GifiD) ® Choose the Sheridan_InD.pdfs file and select the Open button
[ )
T — T —— Select OK
Document Setup... Al+Chl+P ([ i==m
Document Presets 3 [l
D e
|Fil= Lrifen s i
|Fi= i e e s ik i [EEE]E Presets: Look in: I_)InD—CS_PDF_ExpcuI j ° x, B v
Eaclagen AlEEhei] = [EerhatEltayEre]! 5
Packazalmﬁnbve CHie e y Srreen) Cancel
Fiint Presets > e UFE POE grmt]
Piit.. ke ress] Mew,..

PDFf¥-1a]

PDFf¥%-3]
Eul e Acrobat 6 Layered] b
El = = Delete

Preset Settings:

General

’lﬂnacll
o
Y
g

Compatibiity: crobat 5 (FDF 1.4)
Shandards Compliance: Mone
Generate Thumbnails: S
Coptimize PDF: Gn 4|

Export PDF

File name [sheridan = Open
Presst [shencn = Fiesoftype:  [PDF Export Fresels Files =] Cancel
7
CETR e
Marks and Blasds ez
Adyanced & al
ey ® i
L The Sheridan InDesign PDF Export Preset is configured as follows:
— Optiong

Compatibiity; [Acrobat 4 (POF 1.3) ~
N o — Sheridan PDF Export Preset configuration: General

™ Embed Page Thumbnais I™ wiew PDF after Exporting
[~ Optimize for Fast Web Wiew 7 Greate Aot Layers

— Include
I~ Bockmarks I™ eBook Tags
I Hyperlinks I Interactive Elements

I han-Printing Dbjects MUltrneda: [Us= Object Settings B

I~ Vishle Guides and Baseline Grids

B T

Export PDF

Presets [eherin E Sheridan PDF Export Preset configuration: Compression
Compressian
==
Marks and Bleeds — Colar Images
By ancad [Do ot Downsample | [0 mixels per inch
ii:"u::,v for images above: IS0 pixels per inch

Compression: [ Automatic - Tile Size: [256
Image Quaity: [Maximom -

 Grayscale Images
Do ot Downsample =] [0 ks per inch
for images abover [I50 piels per inch

Compression: [ &utomatic = Tie size: [256

Irnage Quality; [Maximum >

 Monachrome Images

Do Mot Downsample =[50 ks per inch

for images sbave: W pixels per inch

Campression: | CCITT Graup 4 >

IV Compress Text and Line Art ™ Crop Image Data to Frames

Save Preset,.. Cancel
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Export PDF
e 5 Sheridan PDF Export Preset configuration: Marks and Bleeds
Marks and Bleeds
ks et e Note: For single-page bleed documents (ad pages), 0.125” (9pt) bleed
Advanced 7 &l Printer's Marks Type: |Default - " b . d fOF a” age sides
Security
== d i N must be assigne pag .

I~ Registration Marks Offset: .n‘125 in

I~ Color Bars
I~ Page Information

— Bleed and Sug

™ Use Document Bleed Settings
Eleed:

Top: ED.IZS in - Inside: ED in
T S REET outade: 50,1251

I™ Inclucks Shug Area

e T

| Sheridan PDF Export Preset configuration: Advanced

o e = Notes: Alternatively, selecting CMYK from the Color drop-down list
Destination Profie: I will accomplish color space conversion to CMYK (e.g., for RGB
™ Irchede 10T Profiies . .
T, ik Mg, .| elements) in acc'ordance with configured Color Management
i settings and designated ICC profiles (PANTONE spot color as-
ot ntert Proies [ | signments remain unchanged).
e e e e Exporting as Adobe PDF accomplishes font conversion to CID
R e e e type fonts (composite, Identity-H encoded).
[~ ORI
omit for OF1: [~ EPS [ POF [ Bitmap Imagss
: Trarsparency Flattenar
Freset: | [High Resci.ition] |
W Ignore Spread Ovemides

Save Freset... CEpt ] cancsl |

Expoit PDF

. . .

st [orercon 5 Sheridan PDF Export Preset configuration: Security

General Sacurity

Cormpression

Marks and Bleeds Encryption Level: Low (40-bit RC4) - Compatible with Acrobat 3 and Later

Advanced — Document Open Passward

B I™ Kot  password to open the document Sheridan PDF Export Preset configuration: Summary

Document Open Password:
Edit PDF Export Preset
— Permissions
I~ Use a password to restrict printing, editing and other tasks Mame: [Sheridan
Permissions Password: General Sumrmary
i) This passusard is raquied o open the document in PDF editing applications. i oanp s 206
Marks and Bleeds General ﬂ
P Al
Prining allswetts [ Resolition = adianced Spread OFF
summary [T
Changes alawed: [ ny except extracting pages = g‘;ﬂ:’ﬁﬁg‘mﬁgggm
Oplimize PDF : OF
View FDF after Exporting: O
ISP o1 oy G e et e ke et e

Include Bookmarks: OF
Tnclude Hyperinks: OFF
Expont Monprinting Objeets: OfF
Expont Visible Guides and Baseline Grids: OF

Include eBook Tags: OF
Include Ineeractive Elements: OF
Hulimedia: NJA

Compression
Color Images
Save Preset,.. Cancel o Sampling Change
for images above: 460 DFL
Comprassion: Automatc
Tie Size: HjA
Qualty: Msmur

g g
Mo Sampling Change:
for images abawe: 450 DR
S AT
Tile: Size: Mg
e e ]

Save Summary...
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Document Preflight:

& Adobe InDesign CS 3.0.1

Fie Edt Layow Tope Obisct Table Wiew Window Help ® Save the completed InDesign CS document

New » = | & E‘ 1

— . .

s |1 = * Select File > Preflight

Open Recent 3
_ Dpenferet  'E

Close O S T ® Select Report to save a copy of the Preflight report

Save Chl+5

SaveAs.. Shift+Ctrl+5

Save aCopy. Al+Chil+5

EEveT

Place. CtiksD T

L Note: Resolve any reported errors before

[ summary  E(MERLEY

FDF Export Presets 3 .

il _ Funs _ advancing to PDF Export
e - Links and Images Preflight:  Entire Publication

Document Setup... Al Colors and Inks

Document Presets 3 Print Settings Fants: 1 Fonts Used, 0 Missing, 0 Embedded, 0 Incornplete

Extemal Plugins DFaterta]
File Info.
F Links and Trmages: 0 Links Found; 0 Modified, 0 Missing

Y k Imagesi 0 Embedded, 0 use RGB color space

Package for GoLive..

Frint Presets > Colors and Inks: 0 Process Inks; 0 Spot Inks

Frirt... Chl+F S5 s OFF

o Cuied Extemnal Plug-ins : ¢

Mon Opaque Objects :Mone
Mumber of Docurents i1
Pagination Options ; Mone

2| Sty At an Hicsem [ayers

Package... m&l Cancel |
AN /.

Export as Adobe PDF:

& Adobe InDesign C5 3.0.1

File Edit Lapout Type Object Table View ‘Window Help Y H
= : Select File > Export
Open.. Chil+01 . . .
Open Recent v ® Navigate to a location for saving the exported PDF file

Close Crksd

Save oS ® Select Save as type: Adobe PDF

Save As.. Shift+Crl+5
5, Copy... Alt+CHl+S .
Emret ® Assign a file name
Flace.. Chl+Dr
Iport XML ® Select Save
FDF Export Presels 5 .
B — N ® Set the Preset to Sheridan and select the Export button
Document Setup.. Al+Cil+P
Document Presets 3

Ll Export 2]
Savein |5 example e r =mE- Prset: [Sheridan =

Preflight.. Alt+Shift+ Ctil+F
Package...  Alt+Shift+Cil+P
Package for Golive:

General
Print Presets » Compression
Piint Clil+P Marks and Bleeds — Pages
B — Adwancad & al
Ezit Ctrl+Q Secuity M) ll—
Sy I Spreads
~ Options

Compatisilty: [Acrobat 4 (PDF 1.3) -
Standard; [None -

™ Embed Page Thumbnals I™ View POF after Exporting
[ Optimize for Fast Web View [ | Greate Acabiat Layers

— Include
™ Bookmarks I~ eBook Tags
I™ Hyperlinks ™ Interactive Elements
I m Bl 5 I Mor-Printing Objects wtmedia [use Chisct Settings 2
File name: examnple,pdf ks I™ visible Guides and Baseline Grids
o
Saveastype:  [Adbe FOF =
7|

Save Preset.., Cancel
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