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Adobe InDesign CS2 (Windows) Export Adobe PDF

Adobe’InDesign’cs2

Preliminary configuration:

& Adobe InDesign C52

F\\am Lapowt Tppe Object Table “iew ‘window Help Conﬁgure InDeSIgn Cs C0|or settlngS:

1 ] el . ISt o= EI = Y EI =l ° . .

J T Sitits B el S Select Edit > Color Settings
B [t
(- [Eapy (St 5

| = [Eir]

~ Faste tithout Earmathna) Sttt =

S Fastelnt Al

‘D‘ EasteitnBlace: Fechii e Bl

2. O Backspace

E [Tuplizate Al SR

‘*\ Step and Femeat. Al

022 | SelEonel Cil2 °
7 WEeselect Al Gt SeleCt the Load bUtton
. i ® Navigate to the folder containing the Sheridan Color Settings file*
=l
= BibEnt ® Choose the Sheridan.csf file and select the Open button

|__/'! P I ExE Al
AE ghgling 3
—ﬁu Transparency Blend Space v *Alternatively, prior to loading, the Sheridan.csf file may be located to:

Transparency Flattensr Pressts

M C:\Documents and Settings\[local PC name]\Application Data\
i) Fieliil=

it Adobe\Color\Settings\
Keyboard Shortcuts.
Preferences 3
Color Settings Load Color Settings K E3

Unsynchronized: Your Creative Suite applications are not synchronized
for consistent color, To synchronize, select Suite Colar Settings in Bridge.

Lookin: [ Calor 3 e N A e

Settings:

¥ Advanced Mode

— Working Spaces

RGE: IMDnItUr RGE - sRGE [ECE1966-2,1

Ll

CMYK: |U‘S‘ web Coated (SWOP) w2

— Color Management Policies

RGE: [Off |
8 vk [of |
Profie Mismatches: [ Ask When Opening
= ek b Basting
Missing Profiles: = 26k Vhen Opering (RIS IShendan ot j gosn )
Files of type: [ Fies = arcel A
— Cohversion Options
Engine: |Adnhe (ACE) j
Intent: IREIatwe Colorimetric j

¥ Use Black Point Compensation Use Adobe Dialog

Description:

Pasition the pointer ower  heading to wiew a description.
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Color Settings

° . . .
Synchronized: Your Creative Suite applications are synchronized using SeIeCt OK from the COlOr Settlngs dlalog WlndOW
the same color settings for consistent color managemment., \

¥ Advanced Mode Save...

— Working Spaces
RGE: [ Adobe RGE (1938) =l
Qv [U.S. weh Coated (SWOR) v2 =

— Color Managerent Policies

RGE: |Preserve Embedded Profiles
a cuvic [off

Prafile Mismatches: b Ask When Opening
¥ sk When Pasting

Missing Profiles: ™ Ask When Opening

— Conversion Options

Engine:; | Adobe (ACE)

Ll <

Intent: |Re\ative Colotimettic

¥ Use Black Point Compensation

Description:

Pasition the pointer over  heading to view a description.

o S e e Color Settings can be synchronized with other Adobe CS2 applications:

File | Edit Tools Label Wiew ‘window Help

Wi e
£ — .
® Launch Adobe Bridge
=1 s
Sty BH{HE
AN iy ridge Cente ® From the Bridge Center menu, select:
8| Ouplicate it
%] . . . .
Selectel B BUED FILE GROUPS Edit > Creative Suite Color Settings...
»
Gelectlateled (St Al thin the st
open within the suite ap)
& S e BB T s 2 2 aroup ¢
B It Selestion (Cirl St I te-open the files in the 1
| Deselestial CifShfi:
= Find.. CHilF
LY Search Adobe Stock Phatos, wﬂﬂﬂ
19 Apply Camera Raw Settings vl
P& fiatste 607
Flitate 07 Blackise (St
Hatate QiR Eaunterc oefemise (St )
Camera Raw Preference:
Sciipt Manager..
Preferences CHlek

il

e Color Settings

By Not Synchronized
Your Creative Suite applications are not synchronized for consistent color.

“Apply" will synchronize Creative Suite Color Settings, ° Se|ect the APPIY button

i Japan, RGE content is converted ko sRGE. =]

® Select Sheridan from the Suite Color Settings list

North America General Purpose Defaults
General purpose colar settings for consistent color handling across Adobe
software-praducts in Morth America,

Photoshop 5 Default Spaces
Preparation of content using the default warking spaces from Phatashop 5.

Sheridan

U.S. Prepress Defaults
Preparation of content For comman press conditions in the .5,

web Graphics Defaults
Preparation of content for the worldwide web (W),

¥ Show Expanded List of Color Settings Flles

Shiow Saved Color Settings Files | Apply & I Cancel
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Confirm InDesign CS2 Preferences for Appearance of Black:

File | Edit Layout Type Object Table “iew Window Help

F Unda Calor Settings Ctl+2 .
J B oaen Sl l; ¢ Select Edit > Preferences > Appearance of Black...
i [Eutt [Etr 5% .
<| G b ® Select Display All Blacks Accurately for On Screen
= Haste [er] 50
LY P st without Formettng) GriftHs £ ° f .. .
—| el Ay Select Output All Blacks Accurately for Printing/Exporting
‘}‘ FFaste iiFlass) At
<] ok Backopace ® Activate the checkbox for Overprint [Black] Swatch at 100%
E [nlicate: e ek )
= Stemant Fefest Al [ se'eCt OK
02 | Celectal i+
7 [VeselestAll ShiifteEi 2
G| B Note: The checkbox for Overprint is invoked by default
= EdifirStar Editar [Et] =y
@ Guick Apply Ctrl+Enter
Fircl gz . wills
/ Firrel ez Al Eirleh
£l Speling e General ~| Appearance of Black
i
~—— Transparency Blend Space 3 Advanced Type Options for Black on RGB and Grayscale Devices
B L Transparency Flaltener Presets Compasiton -
R On Screen: |D|sn\ay All Blacks Accurately j
Color Settings.. e
AesimnProfies: ————— Printing / Exporting: IOutput Al Blacks Accurately j
ContialReil Diictionary Ezample of 100K Black Example of Rich Black

Keyboard Shortouts. Spelling
General Ctrkk. Autocorrect a a

Story Editar Display
Type...

Display Parformance

Avarces Type
Compasition. File Handiing Overprinting of [Black]
Urits & Increments. ¥ Overprint [Black] Swatch at 100%

Grids...
Guides & Pasteboard...

Description
Position the pointer over a heading to wiew 3 description.

Dictionary
Autocorreet...
Speling

Story Editor Display..
Display Performance,

Cancel
3

Configure InDesign CS Transparency Blend Space*:

File | Edit Layout Type Object Table “iew Window Help

Unda Calar Settings Chrl+Z i E B — B .

Jﬁé Fieds Shif i I; mjg :I'W ZE j ® Select Edit > Transparency Blend Space > Document CMYK
mmm CUb [Et] 5
(- (Sapy: [Ei =5

— = [t s .

g S - Configure InDesign CS Transparency Flattener Presets:
e EEstelrt Al

g.‘ e ® Select Edit > Transparency Flattener Presets...
b=

| Duplizate AR Fmanti fan) L] H 4

'j SiEmar Hereat Al seIeCt [ngh ReSOIUtIon]

022 | colbohel Cirls2 °

7 [TEselEnt il Gt =5 seIeCt OK

s@‘ Eelt Origil

iy e Al i

@ Quick Apply CtkEnter File | | Edit Layout Type Obect Table View ‘Window Help

FirdrEhatae.. (Eirlh Unda Color Settings CtikZ o = _

Qg FrdiN et Al Hedt: ShiftH el L :II W ig :II

= Sl ut Bl

— Document RGB Eeje) (Sl

u
=

Paste (et
Fastewittout Earmattng ShiftE
Fastelhta Al St
Eastein Blace Al ShittErE Transparency Flattener Presets
[Efearn Baclspace)

Transparency Flattener Presets.

@

Color Settings..
AssiatProhizs;
Canyetto Frafile..

Presets:

[Lows Resolution] -
NMediurm Resolution

Keyboard Shartcuts.
Preferences

Duplicate oleas]i s i ke )
Step and Fepeat: Al

SElEet Al (et
[eseleshfl ShiftEes

|2 e e 1 Edlifs,,
. Edit i Stary Editor (St
*Note: Transparency Blend Space determines i o e = e
" -
the output color space subsequent to Fing/Change. Bl Preset Settings:
P P q il I Rasterfvector Balance: 100 o _ tead. |

Line Art and Text Resolution: 1200 ppi

Gradient and Ilesh Resalution: 300 ppi Save...

flattening for documents containing
transparent objects. Trarsparsncy Blend Space Gomvan Al bt o o O

Elip Somplex Regions: MiA

Speling

Calor Settings...
Assian FafilEs
[EarinvErtbafErefil=:
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& Adobe InDesign C52

File Edit Layout Type Object Table “iew ‘wWindow Help

Configure InDesign CS Document Presets:

gew mnb i - ;ILEI =
pt " &= == = ) ]
e o E T ¢ Select File > Document Presets > Define
pen Recent 3
e e ® Select New*
Saveifs.. ShittrEt e ° .
v aerson.. Assign a Document Preset name
Srare e Bopy Alt iRt e
| et ® Configure fields for Page Size, Columns, and Margins relative to
Elaze (Eifi0) o . . . .
Ipar L. the specifications for the particular publication
Adobe PDF Pressts 3 .
Breait e ® Select the Facing Pages checkbox

D nent Pr
Documen! Setip.. AsCli-P %DM] ® Set Bleed and Slug to 0 for all page sides
(il Lt Shift e
[ ]

Erefliaht At SeIeCt OK
Faclkage, . Al Shift Sl
Fackage o Ealive:
Pi Pt . New Document Preset
itk [etr +

Presets: Documnent Preset: Iﬁ %9
I aaklen S5E k
Exit Chl+ Cancel MNumber of Pages: |5 ¥ Facing Pages ancel

¥ Master Text Frame

Edit... :
h DEIEEE

Fewer Options
— Page Size: ICustDm -

width; EE in Crientation: @ |eg)
Height: Eg in

Preset Settings:

*Note: Repeat to add Document Presets Preses [Dafaut] iI Load.. T
. . . . . Pags information
for varying publication specifications Ml _ oo | tember: [T sutter: [FJo 1667 in
Master Tert Frame: Mo
B L“‘ﬁ.;'ilfi o =l — Margins

Top: ED.ZS in .
E S
Bottom: ED.ZS in

— Bleed and Slug

Inside: EU‘ZS in
Outside: EU‘ZS in

Top Bottom Irside Cutside
Blesch [0in Join Join Join *
Slug: [0in Join Join Join E-

& Adobe InDesign C52

File Edit Layout Type Object Table “iew ‘window Help

Use Document Presets when creating a new InDesign CS document:

® Select File > New > Document

Open... Chrl+0 Book.
Biowse ACHld Ly
| Geenfecert) M ® Select the pre-configured Document Preset from the drop-down
Llose (St . . . . .
B b list appropriate for the particular publication
Gavess.. Sttt
Saye e erEon, [
Save altopi. At Pa seIeCt O K
Hevert
e, B Now Dacuncn
| ijeiel e ] 59
Adobe PDF Presets Document Preset: | [Default] =l [ OK ] Dacument Preset:
Erpatt. CiE Murnber of Pages: [Custom] Carcel MNumnber of Pages: IS [¥ Faring Pages
Documert Pressts L [Default] [V Master Text Frame

Document Setup... AbClP

Save Preset...
) ) - Page Size: |Letter (74 1p — Page Size: ICustDm -
FilElnas " AleshitBiH = o375 ¥ 10.875 R Fewer Options _ - Fewer Options
e widthi 7135 n CTEMTaTOT | 5] T st (25 in Orientation: | g 3
Fackage.  AlGhiftet - Height: En in Height: EQ in
Fackane fonGEelve)
Prirt Presets »
— Columns — Colurring
it
Mumber; El Gutter: Eumw in Nurnber: El Gutter: 50‘1567 in

L[z ek =
Exit Ctrl+0Q - Margins — Margins

639

Save Preset...

Top: ED.ZE in .
E
Bottom: ED.ZS in

— Bleed and Slug

Inside: EUQS in

Top: ED.Sin .
&
Outsice: EU‘ZS in

Battom: [H0.5n '

— Bleed and Slug

Inside: ED‘S in
Outside: ED‘S in

Top Bottom Inside Outside Top Bottarm Inside Outside
Bleed: |El in |El in |El in |El in E Bleed: |D in |D in |D in |D in E 3
Slug; |El in |El in |El in |El in & Slug: |D in |D in |D in |D in E 3

THE SHERIDAN PRESS
—_—

page 4



InD-CS2_PDF_Win.indd v1 DS 10/12/06

Adobe InDesign CS2 (Windows) Export Adobe PDF

C52

File Edit Layout Type Object Table Wiew ‘Window Help
New 3 7| Y= |
Dpen Chl+fl = Il o = °
Browse... Alt+Crl+0
Open Recent 3
°
[Efase [etrltet
Gave [5G
Saveifs.. ShittrEt e [ ]
ey eI TSN ..
Srare e Bopy Alt iRt e
hievert: d
Elaze (Eifi0)
|y mie | B °

i}

Expnrt

Document Presets

&
[t it o]

LS (0 A =

Document Setup.. Al+Clil+P (PR
[Bress [l

|Fil=a Lifens Al bttt [Birellest EieiGizs]

Erefliaht At

Faclkage, . Al Shift Sl

Fackage o Ealive:

Print Presets r

Fiifit:e: [etr +

I aaklen S5E

Exit Chl+)

Adobe PDF Presets

Load PDF Export Pr

Configure InDesign CS PDF Export Presets:

Select File > Adobe PDF Presets > Define

Select Load

Navigate to the folder containing the Sheridan Adobe PDF Preset

Choose the Sheridan_IND.joboptions file and select the Open button

Select Done

Presets; Laak in: | ) PDF_Enport ﬂ @ T ° -
[ sheraan_IND joboptions
[POF/x-1a:2001]
[PDF/x-3:2002]
[Press Quality] New
[Srnallest File Size]
z et
Preset Description: DEIETE |

Use these settings to craate Adobe PDF documents  + |
for quslity pinting on desktop printers and prosfers.
Crestad POF docurnants <an be apened with

Adobe PDF Presets

Presets:

[High Quality Print] N

[POF/%-12:2001] Lz
[PDF{x-3:2002]

[Press Quality] ew...
Srnallest File Size
Edit...
Preset Description: Delete |

5]

Use these settings For creating PDF Hles For
subrmission to The Sherdan Press. These settings
configured for Acrobat w7.0 01j2005,

Arobat and Adobe Reader 5.0 and later. & - &
L] - Jod| e
Preset Settings Summary: Preset Settings Summary:
POF PresetdHigh Quality Print] - ! : | POF Preset:Sheridan -
Compatibility shcrabat § (PDF 1.4 T Compatibility stcrobat 4 (PDF 1.3)
Standards Compliance/None Standards Compliance/None
[+ General —a [ General
J» Compresson "‘: > Compresson
[» Marks and Bleeds &l J [» Marks and Bleeds
p— Wy Hetwark p— |
Pla
Warnings: File name: | snerdan_IND joboptions =l I Warnings:
1) The preset specifies source profles that don't n n - .4 =]
b i e Gl e, v e Flag of byper |#dabe POF Craation Settings Fies | nbepticns) | =g

by the calor sattings fil will be used.

=

]

A

Export Adobe PDF

Adobe POF Preget: |Shendan j

Standard: |None - compatiblity: | Acrobat 4 (PODF 1.3) -
2

Compression

The Sheridan InDesignCS2 Adobe PDF Preset is configured as follows:

Sheridan Adobe PDF Preset configuration: General

Matks and Blaads Descrption: || bse these settings for creating FOF files for submission to The =]
s Sheridan Press. These settings configured for Acrobat v7.0
et 12005,
Advanced
Secuity |
Summary
— Pages
Al
" Range:
™ Spreads
— Options

™ View POF after Exporting
= Greate Acratat (ayers

™ Embed Page Thurmbnails
™ Cptimize for Fast Web Yiew
™ Create Tagged POF

— Include
I™ Bookmarks ™ Mor-Printing Objects
™ Hyperlinks I™ Interactive Elements

I™ wisitle Guides and Baseline Grics

wuitimedia; [Use Object Settings -

Export I

Cancel

Save Preset...
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Export Adobe PDF

e FOF Presets [Gr2min | Sheridan Adobe PDF Preset configuration: Compression
spwa o compatity [acrcbst + PP 137 5]

Cormpression

. Color Images

Marks and Blasds
- [Do Nt Dawnsample: | [F0 pixels per inch
Adwanced for images above: |50 pixels per inch

Secuity
I Compression: | Automatic (JPEG) - Tile Sige: [128
Image Quality: |Maximum -

— Grayscale Images
|Dn Mot Downsample | |3EIEI_ pixels per inch
for images abowe: [0 pikels per inch
Compression: IW Tile Size: W
Image Quality: lm’
— Monochrome Images

|Dn Mot Downsample | [1200 pixels per inch
for images abowe: [1=00 pixels per inch

Compression: [CCITT Group 4 -

¥ Compress Text and Line Art ¥ Crop Image Data to Frames
Save Preset.., Export I Cancel |

; ;
Sheridan Adobe PDF Preset configuration: Marks and Bleeds

Adobe POF Preget; [Sheridan =l
Standard: |None - Compatiblity: | Acrobat 4 (PDF 1.3) -
Merks and Blecds Note: For single-page bleed documents (i.e., ad pages), 0.125” (9pt)

 Marks bleed must be assigned for all page sides.
Output 7 &l Printer's Marks Type: |Default -
Advanced IV Crop Marks : l—_[
Securiry I” Bleed Marks Height: 0. 125 pt

Summary ™ Registration Marks Offset: 50‘125 in

I Color Bars
I™ Page Information

— Bleed and Slug

™ Use Document Bleed Settings

Bleed:

Top: ED.QS in " Inside: 50‘125 in
Bottom: .0.125 in - Outside: .0‘125 in

™ Include Slug Area

Save Praset,., Cancel

; ;
Sheridan Adobe PDF Preset configuration: Output

Adobe POF Preget; [Sheridan =l
sganrd [None E Compatibity: [crcbat # (OF 1.3) E Note: Alternatively, selecting Convert to Destination (Preserve

e TR Numbers) from the Color Conversion drop-down list will
Cormpression - . .
ks o s o accomplish color space conversion to CMYK (e.g., for RGB ele-
Color Conversion: IND Color Conversion j . . .
] Bestitions [ B ments) in accordance with configured Color Management settings
- Erofle Inclusion Poiy: [inchude Tagged Source Frofies =] and designated ICC profiles (PANTONE spot color assignments

I= | Simulate Gverart Ink Manager. .. remain unChanged)'

— PO/

COutput Intent Profile Name: INIA j

Output Concition Kame: [N/&

Qutput Condition Identifier: |NfA

Reqgistry Name: |N,/‘A

- Description

Position the peinter over 3 heading to views 3 description.

Save Praset,., Cancel

THE SHERIDAN PRESS

page 6
()



InD-CS2_PDF_Win.indd v1 DS 10/12/06

Adobe InDesign CS2 (Windows) Export Adobe PDF

Sheridan Adobe PDF Preset configuration: Advanced

Addoa POF Pragat: [Sherican =l
Stancarcl: |Nong - Compatibiity: [Acobat 4 (PCF 1.3) -]
[eneral Achanced
o Ferits
Py ard Bleads
g WWmeddwmrsmdislasum:h%
IR e ey pmme e i
[Secunty
summary — Cfl

Omit for OFL: [ EPS [ POF I Sitmap Images

Tramsparency Fattaner
Bres=t: | [Hgh Resolstion] |
¥ Tgnore Spread Cvaides:

Job Definition Format (I0F)
I™ Craste JOF Fie Usng Acrobat

4 Fugurar Adoka Acbiat 7.0 Profussional o ba installed, Checking this optien asutomatically databicts
the “Spreads” option i the General paval.

Save Praset... cocdd |

port Adobe PDF

Adobe POF Preget; [Sheridan

Standard: |None - Compatiblity: | Acrobat 4 (PDF 1.3) -

Security

Sheridan Adobe PDF Preset configuration: Security

(General

[ Encryption Level: Low (40-hit RC4) - Compatible with Acrobat 3 and Later
Matks and Bleeds
Cutput i Document Open Passwordt
acerca I Require a password to open the document
Summary Docurnent Open Password:
- Permissions

I~ Use a password to restrict printing, editing and other tasks

Permissions Password: |

i) This passusond i requird ta cpan the docurmant in FOF cltng appicatons.

Printing Alawsd: [High Resclution =

Changes Allowsad: |Amy except extracting pages j

e | et copying) ol eontent are) stsess fur e visusly inpEies

Save Praset,., Cancel

, .
Sheridan Adobe PDF Preset configuration: Summary

Adobe POF Preget: |Shendan j
Standard: |None - compatiblity: | Acrobat 4 (PODF 1.3) -
General Summary
Compression

DESCHHION: | Lse these settings for cresting PDF fles For subrmission to The Sherdan Press, These |

s iR settings conRqured For Acrobat w70 02005,

utput
Advanced b
Secuity
Options: POF Preset:Sheridan ;I
Compatiblicy sicrobat 4 (POF 1.3)

Standards Conpliance Hone
s General
> Gomprassion
> Marks and Blasds

[+ Qutput
[ Advanced
[ Security
Warnings: =

Save Sumimar:
Save Preset.., Export I Cancel
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& Adobe InDe C52 .

Fle Edt Lacu Type Objzct Table Yiew Window Hel ¢ Save the completed InDesign CS document
New Y [
Open Culdd ° . .
B AteCus0 BEET Select File > Preflight

-

Open Recent

® Select Report to save a copy of the Preflight report

Cloze Clrl+a

Gaye IG5
Save fs... Shift+Cll+5

ey eI TSN ..
Savwe a Copy. Alt+CHl+5
hievert:

Flace. Chl+D
Impart $ML..

Adobe PDF Pressts 3

Evport.. euke [Prefiht -

I Note: Resolve any reported errors before
Document Presets 4 m 5 .
Dosumen! Setun._ AsCUF: LR advancing to PDF Export

Fonts
File Infa... AlShift+ChlH Links and Images Preflight:  Entire Publication
Colors and Inks
s et Print Settings Fonts: 1 Fonts Used, 0 Missing, 0 Embedded, 0 Incomplete
ackage...  AltShift+Cil e O Pt
Package for GoLive..
Piint Presets e Links and Irnages: 0 Links Found; 0 Madified, 0 Missing
Frint... Cti+P Images: 0 Embedded, 0 use RGE color space
InBooklst SE
D — Galors and Inks: 0 Process Inks; 0 Spot Inks
Exit Chrl+0) CMS i ON

External Plug-ins 1 1

HNan Gpaque Objects ibane
Humber of Documents 1
Pagination Options 1 Mone
[ | Shmiy: Data oy HiaE e Dasument Layers

Package... Report... ancel |
Export as Adobe PDF:
&8 Adobe InDe C52 ° .
File Edit Lapout Type Object Table ‘iew ‘window Help select Flle > Export
New [ — = E_
Open.. Ctrl+0 H H H
e " ® Navigate to a location for saving the exported PDF file
Browse: Alt+Chrl+0
Open Recent
[ ] .
o —" Select Save as type: Adobe PDF
Saye [EE1ES
Save Az Shift+Cll+5 ° Ass|gn a file name
Sz At erson ..
Save a Copy.. Al+Chil+5
Revet ¢ Select Save
Place.. Chl+Dr ° .
Import L Set the Preset to Sheridan and select the Export button
Adobe PDF Presets 3
Document Presets 3 Export 2] =] Enport Adobe PDF
Document Setup... Al+Chl+P -
- e Saveint |5 exanrle Hor G- Adobe PDF Preset: [sheridan
ile Info. 5 hift+Ctrl+
Standard: |Nane Compatibility: | Acrobat 4 (PDF 1.3) %
Preflight.. Alt+Shift+ Ctil+F
Package...  Al+Shift+Cil+P General
Package for GoLive.. e
Print Presets 2 Marks and Bleeds Description: |fUse these settings for creating POF files for subrmission to The =
Print CulsP - [heridan Press. These settings configured for Acrobat v7.0
:‘”“' ’ I01/20/05,
Advance:
InBooklet SE. . — =
Exit Chl+0 Surnrnary
— Pages
Lol
 Range:
I Spreads
_ Options
I™ Embed Page Thumbnails I™ wiew PDF after Exparting
I™ Optirmize for Fast Web iew I= | Greate fornobiat Layers
I™ Create Tagged PDF
File name: Iexamplalpdf j Save -
— Include:
V]
Save as type: IAdube FDF j ™ Baookmarks ™ MNon-Printing Cbjects
™ Hyperlinks ™ Interactive Elements
™ wisible Guides and Baseling Grids Multimedia: IW
Use Adobe Dialog
//A Save Preset. . Cancel
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